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These experiment instructions are supposed to give a working guide for the laboratory 
task “Sequence control of the drilling machine” to Czech students of the international 
bilateral project: “Experimental work and Simulation of Control systems” subproject 
”Industrial use of PLC and Control Systems” which is carried out in laboratories at the 
University of Applied Science Zittau/Görlitz, Germany. The project was developed in 
cooperation of the Technical University of Liberec and the University of Applied Science 
Zittau/Görlitz in 2005. 
 
The objective of this laboratory exercise is to familiarize the students with the 
programming of a control system S7-300 using STEP 7, which is supplied with the 
optional package S7-GRAPH  FB for a sequence control.  
 
The subproject ”Industrial use of PLC and Control Systems” is carried out as the 
“International laboratory exchange programme” and this student’s guide was partly 
financially supported by the EU – Small projects of Euro region Neise-Nisa-Nysa, Nr. 
CZ 2003/005 - 095.03.01- 0083 in 2005. 
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1 Introduction 

SIMATIC is a worldwide established automation system for implementation of industrial 
control systems for industrial use. The programmable controller SIMATIC S7-300 is 
know as one of the automation systems which enables integrated configuration, data 
management and communication throughout the complete automation system. The 
basic tool for SIMATC 300 is STEP 7 that offers the following languages: instruction list 
IL, ladder diagram LAD, function block diagram FBD, structured control language SCL 
and S7-Graph. The language S7-GRAPH is an implementation of a sequential function 
chart SFC and used for sequence control.  

 
The programming of our laboratory task will provide an overview of the programmable 
controller SIMATIC S7-300 and programming in the environment of STEP 7. The 
objective of this laboratory task is to create a program for a sequencer with Steps and 
Transitions for automatic drilling machine and its testing.  

 

2 Technological Task 

The students will perform laboratory experiments and programming on a model of an 
automatic drilling machine and a programmable logic controller S7-300. The scheme of 
the drilling machine is depicted on the figure 2.1. The programmable logic controller 
consisting of a standard rail, 24V power supply, CPU 314 and a digital input/output 
module (16DI +8DO) is exposed on the Figure 1.1. 
 
 

 
 
 
 

Figure 1.1: Programmable logic controller S7-300 with connections. 
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2.1 Technological scheme of the automatic drilling machine 

The technological scheme on the figure 2.1 shows the set-up of the drilling machine. 
The machine consists of the following elements: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 

- Feeder with feedback signals: “home” and “working position”. The feeder places 
one work piece from the supply bin to working position. The feedback signal 
“working position” indicates that the work piece is on the platform and it can be 
clamped. 

 
- Clamp device with feedback signals: “home” and “working position”. Working 

position indicates that the work piece has been already clamped. 
 
- Work ejector with feedback signals: “home” and “working position”. After drilling 

and release (unclamp) the work ejector removes the work piece and places it in 
the finished pieces bin. The working position indicates that the work piece has 
been removed.  

 
- Supply bin of work pieces with a feedback signal: “bin is not empty”. 
 
- Finished pieces bin with a feedback signal: “bin is full”.  
 
- Support with a drilling head that has two drilling tools. The support has two 

feedback signals: “home” and “working position”. The working position indicates 

Figure 2.1: Set up of the automatic drilling machine 
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that the support with the drilling head has been moved to the bottom limit posi-
tion (down). The home position of the support with the drilling head indicates that 
the support is in its upper position (up).  

 
- The drilling head can work with two drilling tools and it has three feedback 

signals: “Drilling tool 1 is set”, “Drilling tool 2 is set” and “Drilling head rotates”. 
The drilling head is ready for operation and can be moved up or down when a 
drilling tool is set and the drilling head rotates (motor is turned ON). 
The drilling tools can be set when the support is in the home position and the 
drilling head does not rotate. 

 
The air cylinders from the feeder, clamp device, work ejector and support are 
equipped with a spring, which ensures the removal of cylinders to their home 
positions, when the input from PLC is equal to zero. 

 
 
For the performance of the program sequencer the following conditions have to be met:  
 
General conditions: 
 

1) The automatic system of the drilling machine has been switched on with the 
main switch.  

2) The starting of the operational (drilling) cycle is performed by the start 
button. 

3) When the automatic drilling machine is stopped with the main switch then the 
drilling machine parts have to be set to their home position and a complete 
new drilling cycle will be started if the main switch is on again. 

4) You have to feed a work piece, clamp it and than make the drilling head ready 
for operation before you can start the drilling by moving the support in the 
working position. After drilling and moving the support in the home position 
you can unclamp and eject the work piece. 

 
 

Special conditions: 
 

1) Drilling cycle can only be started when the supply bin is not empty and the 
finished pieces bin is not full. 

2) Feeder goes to the home position after the clamp device has clamped the 
work piece  

3) The work piece can be fed only when the supply bin is not empty and it can 
be ejected only when the finished pieces bin is not full.  

4) When the drilling cycle is interrupted because the supply is empty or the 
finished pieces bin is full then the switching ON the start button continues the 
operation after filling the supply bin / removing the finished piece. 
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2.2 Initial state 

The initial state of the automatic drilling machine is defined as follows: 

- The support with the drilling head, feeder, clamp device and work ejector are in 
their home position. 

- The the drilling tools are unset and the drilling head motor is stopped. 

- There is no work piece on the working platform. 

 

2.3 Student’s Task 

Create a program for a sequence control in the environment of SIMATIC Manager and 
Step 7 (S7-GRAPH) for automating of the drilling machine that is described in the 
chapter 2.1. Please carry out:  

 
1) Description of the SIMATIC S7-300 workstation 

2) A concept of dividing the drilling operation into individual steps, 
accepting the given number of variants as well as the general and the 
special conditions exposed in the previous chapter.  

3) Table of Input and Output signals 

4)  Flowchart of the drilling process. 

5)  Program of sequencer S7-GRAPH with Steps and Transitions (Petri Net) 
with programme in LAD (Ladder logic; a representation similar to relay 
logic diagrams). 

6)  Printing the program  

 
The following variants are prepared for the students: 
 
Variant 1 
The drilling cycle of the variant comprises the drilling of only one work piece with a 
rough drill as the drilling tool 1. The following operation is finishing with a parallel 
reamer, which is considered as the drilling tool 2.  
 
Variant 2  
The drilling cycle of the variant comprises the drilling of one work piece with the 
drilling tool 1 and the second work piece with the drilling tool 2. 
 
Variant 3 
The drilling cycle of the variant comprises the drilling of one work piece with the drilling 
tool 1 and the second work piece with the drilling tool 2 (similar to the variant 2).  
It is necessary to wait 2 seconds in the working position before ejecting the work piece.  
 
Variant 4  
The variant is similar to the variant 3 but it is necessary to calculate how many work 
pieces have been made since the time when the main switch was switched ON. 
 
Variant 5  
The drilling cycle of the variant comprises the drilling of 10 work pieces. After 4 
pieces have been drilled, the drilling tool 1 has to be changed for the drilling tool 2.   
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3 Programmable Controller SIMATIC S7-300  

In this chapter the structure of the programmable controller is described. We decided to 
deal with S7-300 Station, the addressing of signals and variables and the functional 
diagram.  

 

3.1 S7-300 Station 

SIMATIC S7-300 is a modular programmable controller – S7 station comprises the 
following components: Rack, Power supply (PS), Central processing units, Interface 
modules, Signal modules (SMs), Function modules (FMs), Communication processor 
(CPs) and Subnets. Generally, the programmable controller may consist of several 
racks, which are linked to one another by a bus cable. The power supply, CPU and I/O 
modules are plugged into the central racks. The rack contains 8 slots for modules.  
Every slot has a fixed address in the S7 station. This slot address consists of the 
number of the mounting rack and the number of the slot.  
 
The I/O modules can be separated from the central rack when expansion racks are 
connected to the central rack by interface modules. 
 
The preparing and programming of a control system for an automated machine is 
performed in a programming device - a PC with Windows. The program of control uses 
the Central processor unit CPU of the SIMATIC Station S7. The programming device 
contains off-line data. A project must be created for every task on the programming 
device. This consists of hardware configuration, user program off-line and symbol 
tables. The on-line data consist of the user program and the system data in the CPU, 
which are stored in the load memory, the work memory and the system memory.  
 
Generally the load memory consists of a user program including configuration data that 
are loaded from programming device. 
 
Work memory is a high speed RAM integrated in the CPU. The relevant control program 
is executed in the work memory.  
 
System memory contains the addresses of variables that the executed program 
accesses. The addresses are accommodated in these areas: input area (E), output area 
(A), bit memories (M), Timers (T), counters (Z) and temporary local data.                                                                                                                          
 
There are 8 I/O modules that can be plugged into the central rack of the S7-300 station 
with a single wire configuration. Our laboratory task uses the S7-300 Station. It is 
equipped with:  
 
 

CPU 314 C – 2PN/DP 
Input and output module: DI 16/DO 16xDC 24V 
Addresses of Input:  E136.0-E137.7  
Addresses of Output:  A136.0-A137.7  

 
 
This hardware configuration doesn't have any assembly racks and neither the slots. 
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3.2 Defining the System Signals 

The switches and the contactor of the automatic drilling machine are controlled via the 
inputs and outputs of the digital input/output module of the programmable controller 
SIMATIC S7- 300 with the Station CPU314. The input/output module has 16 inputs and 
16 outputs. The default values of input addresses to the PLC are E136.0 to E137.7 and 
the outputs from PLC are A136.0 to A137.7 (in our laboratory task we are using only 
A137.0 - A137.7). These addresses are described as Absolute Addresses. It is 
possible to use Symbolic Addresses, for example X1 or “Clamp_in _home”.  
 
A list of INPUT (feedback signals) and OUTPUT signals can be made from the 
technological scheme on the figure 2.1 (See the Tab. 3.1 and 3.2). We decided to use 
the Symbolic Addresses X0 to X14 for Inputs and Y9 to Y15 for Outputs.   
 

Symbolic 
Address 

INPUT explanation Absolute  
Address 

X0 Feeder - Indication of home position E136.0 
X1 Clamp device - Indication of home position E136.1 
X2 Support - Indication of home position E136.2 
X3 Work Ejector - Indication of home position E136.3 
X4 Feeder - Indication of working position E136.4 
X5 Clamp device - Indication of working position E136.5 
X6 Support - Indication of bottom limit (working) position E136.6 
X7 Work Ejector - Indication of working position E136.7 
X8 Drilling head rotates E137.0 
X9 Supply bin is not empty E137.1 

X10 Finished pieces bin is full E137.2 
X11 Start button is ON E137.3 
X12 Drilling tool 1 is set E137.4 
X13 Drilling tool 2 is set E137.5 
X14 Main switch is ON E137.6 

 
 
 
 

Symbolic 
Address 

OUTPUT explanation Absolute  
Address 

Y9 Set Drilling tool 2 A137.1 
Y10 Set Drilling tool 1 A137.2 
Y11 Turn ON motor of drilling head A137.3 
Y12 Remove the work piece to finished pieces bin A137.4 
Y13 Move support in the working position A137.5 
Y14 Clamp work piece A137.6 
Y15 Insert work piece from the supply bin A137.7 

 
 

Tab. 3.1: Input signals (Feedback signals) to the PLC  

Tab. 3.2: Output signals (Feedback signals) from the PLC  
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3.3 Sequential Function Chart (SFC) 

Before creating a program for the sequencer in the S7-GRAPH FB it is necessary to 
divide the drilling machine operation into individual steps. The result is a Sequential 
Function Chart (SFC). The basis for creating the Sequential Function Chart is the 
technological scheme of the drilling machine. After that you can create the program for 
the Sequential Function Chart.. 

 
 
 
 
 
 
 
 

To specify the structure of the Sequential Function Chart, follow the steps outlined 
below: 
 

1) Divide the drilling process into steps and specify the order of the steps! 

2) For each step specify the actions that must be performed in the step!  

3) Decide which conditions must be met for every step so that the process can 
move on to the next step! 

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
It is possible to use alternative branches (see figure 3.2a) and jumps (see figure 3.2b). 
  

A Sequential Function Chart represents a sequence of simple 
steps and transitions (see figure 3.1). The steps are executed 
in a fixed order and the transitions consist of conditions that 
control how the process moves to next individual step.    
 

Step 2 
Action  
 

T1 
Transition 

  S2 
Step2 

  S1 
Step1 

T2 
Transition 

Conditions 1 

Conditions 2 

Step 1 
Action 1 
Action 2 
 

Figure 3.1: Structure of the SFC  
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Figure 3.2a: Structure with alternative branches 
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Figure 3.2b: Structure with jumps 
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4 Creating the Program in the SIMATIC Manager 

The SIMATIC Manager (figure 4.1) is a software tool working with objects in STEP 7 
environment.  
 
 

 
 
 
 
These logical objects correspond to real objects in the technological equipment.  
A project may contain several stations (programmable controllers) connected to one 
another. A station contains a CPU that consists of a program in STEP 7. This program 
is a “container” for other objects such as the “Blocks”, which contain other compiled 
blocks.  
 
 
To select an object means to click on it once with the mouse so that it is highlighted. 
To name an object means to click on the name of the selected object or select the item 
“EDIT”. To open an object means to double click on that object. 
 
 
In this laboratory manual is not possible to describe in detail the SIMATIC Manager, the 
programming in S7 – Graph and other tools. We only intend to offer the information 
necessary for the students to be able to create a sequencer for the control of the 
automatic drilling machine. 
 
 
The basic procedure for using the STEP 7 programming for a new project is the 
following: 
 
 

Set up a new project  
   > Configure the Hardware  
      > Configure the communications  
         > Create a user program  
            > Test the Program 

  
In our laboratory task the communication configurations are set. It is not necessary to 
carry out the complete configuration.  

  

Figure 4.1: SIMATIC Manager 
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4.1 Creating a project and an S7 program 

In the SIMATIC Manager it is necessary to create a new project folder. There are two 
possible ways: without and with the “Project Wizard”. We use the way without the 
wizard because we have to make some changes in the hardware configuration. 
 
There are the following steps to do: 
 

Start SIMATIC-Manager (figure 4.1) 
 

"Options" -> "Customize" -> Path of own USB-Stick or "C:\TUL" -> "OK" 
 

  
 

"File" -> "New" (Ctrl+N) -> Name -> i.e. "SCD_G1" (max 8 Letters) -> OK 
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"Insert" -> "Station" -> "SIMATIC 300 – Station" 
 

  
 ->  

 

 
 
 
 "SIMATIC 300" -> "Hardware" -> open (double left click) 
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 -> 
 

 
 
 
 "Insert" -> "Insert Object" -> "SIMATIC 300" -> "RACK300" -> "Rail" 
 

 
 
 
 "Insert" -> "Insert Object" -> "Power Supply PS 307 5A" 
 

 
 



SCD: Sequence Control of the Drilling Machine by SIMATIC S7-300 

   

15 

 "Insert" -> "Insert Object"  -> "CPU: 314C-2 PN/DP" -> "V3.3" 
 

  
 -> 
 

  
 
 -> "OK" 
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 Close HWConfig (Save changes -> "Yes") 
 

  
 
 -> "OK" 
 

  
 
 
The result is the SIMATIC Manager with the new project and the S7-Program(1).  
If you click through the entries we can see the folder for the SIMATIC 300 Station, the 
folder for the CPU 314C-2 PN/DP and the folder for the S7 Program (1).  
The OB1 is already created. 
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Our task is to create a sequence program with GRAPH 7. The container for GRAPH 7 is 
the Function Block (FB). Therefore it is necessary to create a Function Block. We 
must select the folder “Blocks” and the required steps are the following: 
 
 „Insert“ > „S7 Block“ > „Function Block“ 
 

 
After that the window „Properties“ will be opened and it has to be filled. 

 
 

  
 
 -> „OK“  
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4.2 Creating a Symbol Table 

In the chapter 3.2 we introduced symbolic address-variables. If we want to use these in 
our program we have to create a Symbol table.  
 
It can be carried out by the following steps: 

 
1. Open the “S7 Program(1)” folder by a double left click on it 

 

  
 

2. Open the symbol table in the “S7 Program(1)” folder by a double left  click on 
“Symbols”. 

3.  Edit the table  

4. Save the symbol table using the menu command “Table” > “Save” and exit. 

 
 
By editing of the table you match the required symbolic representation, the Address (for 
Example E136.0) and the Data type of the input or output (BOOL).   
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4.3 Creating an S7 – Graph FB and Programming the SFC 

For the programming of the Sequential Function Chart (SFC) with Steps and Transitions 
it is necessary to create an S7-GRAPH FB.  
 
By a double left click on the FB1 icon (S7 Program(1)\Blocks, see) the system inserts 
the first step and the first transition. To display conditions and actions, activate the 
menu command 
 
 “View” > “Display With” > “Conditions and Actions”.  
 

 
 

 
 
 
 
The Sequential Function Chart has a toolbar on the left side of the window. It includes 
icons for inserting a step and a transition, opening and closing of alternative branches 
and also for jumps. There are two ways of creating a Sequential Function Chart and 
they are described bellow.  
 
 

1) Direct mode 
 
 Start the S7-GRAPH editor by a double click on FB1 

Select the menu command “Insert” > “DIrect” 

 
 
 
 

 

 
 
 
 
 
 
 
 
 
  

 

 

 

 
s 

Select a transition and click with a mouse on this icon and as a result 
you will Insert a step und a transition  
(or “Insert” > “Step + Transition” 

Select a step and press this icon and you will Open an alternative 

branch (or “Insert” > “Alternative Branch” > “Open”) 

Select this icon and then select a transition and you will Close the 
alternative branch (or “Insert” > “Alternative Branch” > “Close”) 
 

Select a place from where the jump starts and then click this icon. 
Then select the place where the jump is directed.   
This is the way how you can Insert a jump (or “Insert” > "Jump") 
 

Figure 4.2: Window S7 GRAPH  -  SFC FB1 
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2) Drag-and-Drop 

Start the S7-GRAPH editor by a double click on FB1 

Select the menu command “Insert” > “Drag/and-Drop” 

 
 
 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 

 

 

 

 
s 

Select the icon “Insert step + transition” with the mouse and 
click on the last transition of the individual element. 

Select the icon “Open an alternative branch” and open an alternative 
branch by clicking on the appropriate step.  
a step and select this 

Select the icon “Close an alternative branch”. First select the 
transition 1 and then the transition 2. The transition 1 defines “from” 
which point the connection has to start, the transition 2 defines, “where” 
the branch should be connected. 

Select the icon “Insert a jump”. First select the transition 
from where the jump starts and then select the step, where 
the jump is directed.  
  
 

Figure 4.3: Creating of an example 
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4.4 Programming a Step Action 

We will use and illustrate only the Drag-and-Drop method. We have to select the menu 
command  
 
 “Insert” > “Drag-and-Drop” 
 

1. Select “Insert” > “Action”. 
 
-> Result: The mouse pointer appears in the position as shown below: 

 

 
 

   (It is possible to exit the mode by hitting the ESC-key)  

 
2. Insert an empty action line by clicking in the action box of a step. 

 
 
 
 
 

3. Enter the action: 

The action consists of an instruction and an address. The following steps are 
necessary for our action: 

 

 S  Set the output 

 R  Reset the output 

 N  Non holding: As long as the step is activated, the signal      
   state of the address is 1. 

 D  Delay. The address is set to 1, after the defined delay it is  
  deactivated and the value of the address changes to 0.   

 
 
 

 
 
 
 

  
 
 
 

  Very easy way: Click with the right mouse button in the step action box 
”Insert New Element” > „Action“ 

 

Figure 4.4: Creating of the Step Action 

  Very easy way: Click with the right mouse button in the step action box 
”Insert New Element” > „Action“ 
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4.5 Programming the Transitions 

The bit logic instructions “open contact”, “close contact” and “comparator” are used to 
enable the step conditions in the transitions. To program the transitions: 
 

1. Set the “LAD” view (“View” > “LAD”) and select the appropriate icons in the 
“LAD/FBD” toolbar  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
2. Place the symbols at the appropriate points by clicking at the transition.  

     (It is possible to exit the mode by hitting the ESC-key)  

3. Enter the addresses. Click on the position and select the required text field. Then 
enter an absolute or symbolic address (for example E136.0 or “X0”). 

 

  
 
 
 
 
Save the Block and exit. 
 
The system will add some necessary Blocks automatically (FC72, DB1, SFC64). 

  

 

 

 

Insert normally-opened contact 

Insert normally-closed contact 

Insert comparator 

Figure 4.5: Programming transitions 
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4.6 Programming OB1 

After saving FB1 one has to program OB1 (in the Mode “View” > “STL”) by opening 
OB1 and typing in (in the space below the second comment) only the first line 
“CALL FB 1, DB1” of the code in figure 4.6 and then “Enter”, the programming system 
will add all the other lines. Save the Block and exit. 
 

 
 
 
 
 

4.7 Downloading and Monitoring the Program 

Go into the level “S7 Program(1)\Blocks” and download the Data into the PLC.  
 
 “PLC” > “Download” 
 
Overwrite existing objects and quit requests for load, STOP and starting with "Yes" : 
 
You can monitor the running of the Function Block; go into the block and  
 
 “Debug” > “Monitor” 
 
 
 
These guidelines cannot describe all the details and specifics of programming a PLC. 
They only provide the instructions that help the students with programming of the drilling 
machine.   

Figure 4.6: Programming OB1 
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